22 agosto 2006

Aviso a Ubunteros: actualización xserver-xorg-core rompe las X


Como Ubuntu está en un principio dirigido a gente que se inicia en el maravilloso mundo del software libre comento aquí lo siguiente: la actualización de xserver-xorg-core --versión 1:1.0.2-0ubuntu10.3-- romperá vuestro servidor gráfico casi con un 100% de probabilidad y os entrará un sudor frío, así que antes de nada NO INSTALEIS LA ACTUALIZACIÓN que os sugerirá el gestor de actualizaciones.

Si ya llego tarde, no pasa nada porque tiene fácil solución y es volver a instalar el xserver-xorg-core anterior tecleando esto en una consola:

sudo apt-get install xserver-xorg-core=1:1.0.2-0ubuntu10

Para no poner aquí más comentarios técnicos, si alguien tiene algún problema que lo diga y espero poder ayudarle.

Actualización: Han reaccionado rápido en Ubuntu y han sacado un paquete corregido, versión 1:1.0.2-0ubuntu10.4

9 comentarios:

Ignacio dijo...

Cerrajero:

SI TU AMADO UBUNTU TE HA ROTO TODA TU COLECCIÓN DE PELICULAS X ME VOY A ESTAR PARTIENDO DE RISA DE AhORA AL FINAL DE SIGLO.

ESO ES UNA CHAPUZA DE PEPIÑO BLANCO!!!!!

anda espabila y pasate a Stalinux

El Cerrajero dijo...

Gracias por tu preocupación Ignacio pero es infundada porque no soy ubuntero sino debianero y no tengo problemas con las 'pelis pommmno' porque tu prima está siempre dispuesta a grabarme más xD

spike_mandrake dijo...

Hola:
Gracias por la advertencia. Afortunadamente esta mañana no me dió por actualizar el equipo antes de irme al trabajo (uso Xubuntu Dapper).
Ahora esperare unos días antes de fiarme y actualizar. ;-)

El Cerrajero dijo...

# spike_mandrake, es la segunda gran cagada que cometen en Ubuntu y creo que no debe llegar una tercera.

Ubuntu es para personas que se inician en Linux principalmente y cosas así pueden hacer un daño en la parroquia irreversible.

Suelen ser problemas que se solucionan fácilmente pero que en Ubuntu no deben ocurrir nunca, porque no estamos hablando de una versión en desarrollo como Edgy, sino la que está en producción, Dapper.

Don Nacho dijo...

asfdasdfadsfadsfadsf

Sin Comentarios :(

PD: Siempre viene bien formatear el HD

spike_mandrake dijo...

Ubuntu no te ofrece ninguna garantía, y eso de que está orientado a los novatos ... no sé yo. Es un Linux. Para usar Linux conviene saber informática.
Yo llevo usando Linux desde Diciembre del 2002: novato no soy, pero me gusta la simplicidad. Por eso me he instalado, pensando en comodidad para el usuario, Red Hat (7.3 y 8), Aurox, Fedora Core, SuSE y Mandrake-Mandriva en la que creí encontra la solución a todo lo que necesitaba como usuario doméstico durante más de dos años y medio. Pero con Mandriva 2006 la cagaron bien. He probado otras distros, como Debian, Slackware e incluso alguna derivada de Gentoo, pero hay que trabajarlas demasiado para cosas sencillas: eso no es plan. Si hay que pegarse con un controlador, vale. Pero tener problemas configurando el idioma o para elegir el escritorio ...
No digo que sean malas: son para gente tal vez más inquieta que yo, gente que gusta aun más que yo de investigar y trastear. Pero me gustan los asistentes, los configuradores, las opciones de control pese a que sea capaz de hacerlo todo por consola. Comodidad. Facilidad de uso. Al fin y al cabo, es mi ordenador personal. Lo quiero para disfrutar. ;-)
Windows también se rompe, pero nadie dice nada: recordemos Blaster y Sasser.
Uhm ... creo que en Debian ha existido un error similar. O eso he leido.
No es que haya una distro mejor o peor: crear software o empaquetarlo puede estar sujeto a errores, a veces terribles, como en este caso.
Lo sé bastante bien: hago interfaces gráficas, y si por un descuido mio olvido una función o añadir cierto valor, puedo crearle al usuario problemas serios.

El Cerrajero dijo...

# Don Nacho, en Linux es prácticamente imposible que tengas que formatear/instalar como con winblows y de hecho en esta ocasión --que sólo ha durado unas horas aunque es imperdonable-- bastaba con instalar una versión previa o, si no habías hecho la actualización, esperar unas horas a que estuviera el paquete corregido.

# spike_mandrake, errores como el cometido con la actualización de xserver-xorg-core se solucionarían si se incluyese en las directrices de actualización de Ubuntu un periodo de 'paquete propuesto' para hacer unas pruebas más intensas. Cuestión de habilitar un repositorio para ello nada más.

Los usuarios avanzados, los que no tienen problemas si algo se rompe, podrían hacer de filtro y 'testing' antes de que llegara el paquete a todos los usuarios.

O eso o que el equipo de Ubuntu aumente las máquinas de pruebas, evidentemente.

He probado muchas distros pero como Debian ninguna ^_^

Don Nacho dijo...

El caso Cerrajero, es que tenia un windows superviviente en ese HD y me hacia ilu destrozarlo a lo bestia :D:D

El Cerrajero dijo...

Así si se comprende Nacho!!!!!

xDDDDD